MFA: Reconnect Duo mobile

Problem:

When trying to login to your Duke account, your Duo push does not work anymore, and then either:

  • you go into the Duo app on your phone, and it has a message roughly stating to 'Reconnect your account' and to contact the service desk to get a code.
  • you do not have the Duo app on your phone anymore

Cause:

The most common scenarios are:

  • you got a new phone
  • you changed the phone number or sim card associated with your phone
  • the app was deleted or the Duke account in the app was removed

Solution:

If your device has a different phone # then what you previously had, then you will need to call the OIT service desk at 919-684-2200 in order to be verified over the phone and to have the new # added to your Duke MFA profile.

If your device has the same phone # as what you previously had, and you think that it is still in your Duke MFA profile, then follow the directions below.

 

  1. On any device, open up a browser, and go here: https://idms-mfa.oit.duke.edu/mfa/home
  2. Enter your NetID and password. You may be prompted for MFA. If so, please generate a temporary passcode by following these instructions. If you are unable to generate a temporary code, see here.
  3. Enter the passcode into the box in the Multi-Factor Authentication section of the page. You can now hit the "Log In" button.



  4. Once logged in, under 'Manage Duo Devices', click on your device that corresponds to your current phone #



  5. On the new page that loads with info about your device, scroll to the bottom, and there is a checkbox next to 'Generate a new QR code to activate your Duo Mobile app'. Check the box and press continue.



  6. The next page has some instructions on how to install the Duo app if you do not already have it installed:
    • Go to the app store for your device and search for 'Duo mobile'
    • Install the app

    And the last step on that instruction page has a QR code that can be used to activate the Duke account inside of the Duo app.

    Alternatively, you can simply press the link on the page which reads, 'click this link to activate instead' which will provide you with an activation code. You will enter this code into the Duo Mobile app by hitting the "use activation code" option during the initial setup. 





  7. If the QR code or activation code worked, then Duo will ask to finish setting up the account. It will ask for an Account name, which is just a nickname for the account and doesn't matter, so put something like 'Duke' or 'Duke University', and then it will look like this in the app:

  8. Once you see this, when you go to login at any site that has the Duke Shibboleth login, the Duo option should now show as an option for you to authenticate yourself with.



  9. If the process to add the Duke account inside of duo fails, then try the following:
    • If you had a Duke account in Duo before, remove the account by clicking on the ellipsis '...' next to the account, and press 'Delete'. Then try to scan the QR code or generate a new activation code.



    • If scanning the QR code is unsuccessful, please attempt to use the activation code instead.

Escalation:

For further support or assistance or if you cannot generate a temporary code on your own:

  • Duke University: Contact the OIT Service Desk at 919-684-2200. Click here for hours of operation.
  • Duke Health: Contact the DHTS Service Desk at 919-684-2243. Click here for DHTS information.

 

Article number: KB0036398

Valid to: November 12, 2025